Womack Army Medical Center, Fort Bragg, NC    
5 September 2007

M2 MEDICAL RECORD ID “HOW TO”

Prepared by:

Clinical Data Analyst

Purpose

· To document the steps to use the M2 Record ID to locate a specific Visit in CHCS Patient Appointment and Scheduling (PAS), or Encounter in CHCS Ambulatory Data Module (ADM), for users with CHCS Filemanager access, Inquire to File (IFE).

· The M2 Record ID can be used by DQ Managers, Business Operations Staff and CHCS Data Administrators to locate specific records that may need to be reconciled or corrected and re-transmitted in the Standard Ambulatory Data Record (SADR).
· The M2 Record ID makes it possible to locate specific Visit/Encounters in your CHCS database, since the M2 Record ID is the same as the CHCS Appointment Internal Entry Number (IEN) in the CHCS PATIENT APPOINTMENT and KG ADC DATA Files.
Process Overview:
· CHCS tracks every PAS Visit and ADM Encounter by a sequential and unique IEN.    This Appointment IEN is sent to M2 from CHCS in the SADR.
· The Appointment IEN is unique to your CHCS Host Platform.

· The Appointment IEN is accessible in both the PATIENT APPOINTMENT and KG ADC DATA files.   Note: The encounter data in the KG ADC DATA file is only accessible by Appointment IEN, when the encounter is complete in CHCS ADM.  
· When designing a detailed encounter record query in M2, include the M2 Record ID.

· When using the M2 Record ID to locate the specific visit or encounter data in CHCS, the ` (grave) key must be concatenated to the Record ID, as the first character.  
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· Depending upon the application used to access CHCS, a listing of up to ~15,000 IENs (using Kea!) can be pasted into CHCS to pull specific data elements from the PATIENT APPOINTMENT or KG ADC DATA files.    
Skills/Access Needed:

· Excel – Basic/Intermediate Excel Skills
· CHCS User Account with Filemanager Access (Inquire to File – IFE) as a Secondary Menu Option
· See also the References Section of this document for additional Web resources on the Web, to further explore Excel features and Quick Tips, particularly Pivot Table Tutorials.  

Sample Scenario (The Scenario is real…):  

· An M2 query resulted in 5,618 encounters still showing as “I” Status for FY06-FY07, but your ADM Compliance Report shows only a total of 2,801 Open.  
· The M2 Record ID will help validate whether the encounters are complete in ADM or whether M2 is missing completed encounters, or possibly that M2 has not yet processed the prior year encounters completed in the current year.  
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Process Steps:

· With the results of your M2 query in Excel, use the Excel Concatenate command to append the grave key (`) to the M2 Record ID:

· Insert a new Column in Excel

· Fill the blank column with the following formula:  =CONCATENATE(“`”,E2)
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· Select Edit->Fill->Down to fill the column with the formula
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· Copy the values from the concatenated column into the original Record ID column by using the Edit->Copy->Paste Special-> Values commands in Excel.
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· Delete the column with the formula.
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· The M2 Record IDs are now ready to use to query CHCS.

Note:  Each Record ID MUST be unique (There cannot be any duplicates)

· Access CHCS Legacy directly (do not access CHCS through AHLTA), with a valid Access/Verify Code with Security Keys for CHCS PAS and/or ADM and Fileman.  
Select PAD System Menu Option: IFE  Inquire to File Entries

Output from what file: PATIENT APPOINTMENT or KG ADC DATA
· Copy the Appointment IENs/M2 Record IDs with the Grave Key (`”) from (Column E) 
· At the CHCS Select PATIENT APPOINTMENT NAME: prompt, or Select KG ADC DATA APPOINTMENT: Paste the M2 Record IDs (all at once) into CHCS.  Kea! Will allow up to 15,000 IENs to be pasted as a single query.
Note:  If there is NO ADM Encounter found in the KG ADC DATA File, CHCS will beep and display ??, however, CHCS will be able to display a record for the Appointments in the PATIENT APPOINTMENT file.   

Output from what file: KG ADC DATA    
Select KG ADC DATA APPOINTMENT: `15815377 ??

Select KG ADC DATA APPOINTMENT: `15884149 ??

Select KG ADC DATA APPOINTMENT: `15286207 ??

Select KG ADC DATA APPOINTMENT: `15289216 ??

This indicates the Encounter is not Coded as Complete in ADM.  
· The KG ADC DATA and PATIENT APPOINTMENT files will return a list of patients with the encounter Date/Time, Provider and Encounter Status.
Output from what file: PATIENT APPOINTMENT  PATIENT APPOINTMENT  

                                     (16783456 entries)

Select PATIENT APPOINTMENT NAME: `15815377  QQQM2,RECORDHOWTO   

30 Nov 2006@0600 PLASTIC SURGERY APV     QQQHCP,PROVIDERTEST

Another one: 

Store these Entry ID's in Template: Leave Blank
Standard CAPTIONED output? YES// Enter NO to select a Print Template
· Use your favorite CHCS Ad-Hoc Print Visit/Encounter Template associated with the KG ADC DATA or PATIENT APPOINTMENT File.
Do NOT SAVE the Pasted IENs as a CHCS query template – the query template cannot be deleted.
· To Select Print Template that includes specific data elements from CHCS

Standard CAPTIONED output? YES// N  (NO)
First Print FIELD: [HISTORICAL CAPTIONED tells CHCS to display the standard detailed output for the visits/encounters selected

Or 

Standard CAPTIONED output? YES// N  (NO)
First Print FIELD: [GS CCC lists all CHCS Print Templates that begin with GS CCC
     1   GS CCC ADM DETAIL          (09/1/06)     USER #14396   FILE #44.2

     2   GS CCC ADM TOTAL DETAIL       (08/11/06)  USER #10960  FILE #44.2

     3   GS CCC APPT QUICK LOOK       (06/20/07)  USER #14396   FILE #44.2

     4   GS CCC CANCEL EXTRA FF       (07/15/06)  USER #14396   FILE #44.2

     5   GS CCC CAPER DETAIL        (06/14/07)    USER #14396   FILE #44.2

Type '^' to stop, or

Choose 1-5: 5  GS CCC CAPER DETAIL
Want to edit 'GS CCC CAPER DETAIL' Template? NO//   Accept Default of NO
Heading: @@//  Accept Default @@ to suppress Heading
Footnote: Leave Blank
DEVICE: Queue to print on
DEVICE: SPOOL  VMS file
Select SPOOL DOCUMENT NAME: CCC CAPER DETAIL TEST
   Are you adding 'CCC CAPER DETAIL TEST' as 

       a new SPOOL DOCUMENT? Y  (YES)
EXPIRATION DATE: 22 Aug 2007//  Accept Default Date or enter new Date
Requested Time to Print: NOW// Enter a Future Date/Time or accept default
Request QUEUED!

The imbedded Icon contains the .txt file for the CHCS Ad-Hoc query that will provide a Delimited Flat File to preview Encounter Coding included in the CAPER (Comprehensive Ambulatory Professional Encounter Record) with up to 3 Evaluation and Management Codes, up to 10 CPT Codes, up to 3 Multiple Modifiers and Units of Service.
Request support from your CHCS System Administrator to Copy the File content to create the CHCS CAPER Preview Ad-Hoc Query.

Note that the query results contain Protected Health Information and MUST be stored on a Secure Server.
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Almost Done!

· Print Spooled file from CHCS
Select PAD System Menu Option: SPOOLER
   DSR    Delete Spooled Report

   PSR    Print Spooled Report

Select Spooler Menu Option: PSR  Print Spooled Report
Select SPOOL DOCUMENT NAME: CCC

     1   CCC ALL WAMC AUG07         13 Aug 2007@091931     COLON,CHARLENE C

     2   CCC ALL WAMC JUL07         13 Aug 2007@091855     COLON,CHARLENE C

     3   CCC CAPER HOW TO TEST         15 Aug 2007@094150     COLON,CHARLENE C

     4   CCC CCE IF STATUS         13 Aug 2007@092516     COLON,CHARLENE C

     5   CCC DEM CAPER DETAIL         14 Aug 2007@091816     COLON,CHARLENE C

Type '^' to stop, or

Choose 1-5: 3  

Number of Copies: 1//

· Capture data from CHCS (Using Kea!)
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· Save to Text File on Secure Server if query results contain Protected Health Information
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· End Capture
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· Have Data Now What???

· Clean up Captured File using Windows Notepad or other Text Editor (Not MS-Word, saved as a Text File) 
· Delete Extra Characters to ensure a clean import into Excel or Access
[image: image11.png]Flo Edt Format View Hel

CLINICAPTAATEN~APPT DT~HCPAT1 IZ*I3I4°C1A




· Import into Excel or Access

· Open Excel
· Select File-> Open (remember to select .txt File Type) 
· Highlight the CAPER CAPTURE.TXT or other captured file…
· Click the Open Button
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· Excel Wizard will guide you through the remaining steps
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Note:  Import ICD-9 Codes and CPT Codes as Text Fields to preserve Leading Zeros.  This is also necessary for Zip Codes and DMIS IDs
· In Excel, Select Format->Column-Autofit to align columns
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Exploring the possibilities - What did the data Show?

Another query that contained the CAPER TRANSMIT DATE showed:

· High number of records still open for SADR Transmission of 14-15 May 2007

· Encounters complete in CHCS but still showing as “I” in M2

· Detail data included the Appointment IEN/M2 Record ID to coordinate reconciliation
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Another view with additional KG ADC DATA elements showed:
· Who Last Edited the Encounter Record not received by M2

· Most Encounters not found in M2 had a Source System of CHCS

· Two Clinic Locations primarily affected
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References:
Well organized index of Excel Topics (Look Here First):

http://www.contextures.com/tiptech.html
Extensive Library of Excel Topics (over 500 Articles):

http://www.mrexcel.com/articles.shtml
Excellent Tutorial on Excel Pivot Tables:

http://www.microsoft.com/dynamics/using/excel_pivot_tables_collins.mspx
Another very well done Tutorial on Excel Pivot Tables:

http://www.exceltip.com/exceltips.php?view=category&ID=32
Power Tips:  (You shouldn’t be without…)

1.  Ever need to highlight thousands of rows of data to select a range of cells? 

· Vertically from top to bottom, press Ctrl+Shift+Down Arrow.

· Horizontally from left to right, press Ctrl+Shift+Right Arrow.

2.  Ever notice the Sum= is on the Excel Lower Taskbar?
Select a range of cells and the Sum will automatically be displayed 
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3.  Need to quickly access different applications?  

Set up a Quick Launch Toolbar to always be able to access your favorite applications
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Here’s How… 
[image: image21.emf]CHCS II Quick  Launch Toolbar.doc


4.  How to Copy Only Visible Cells in Excel?
When cells are hidden, such as when you use Excel Data Filters, and Summary Sub-Totals, but you only want to copy the “Visible” cells…

· Highlight cell range to copy

· Press Alt+ ; (semi-colon) This specifies to copy only Visible Cells 

· Press Ctrl+C (Copy)

· Press Ctrl+V (Paste)
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_1249726575/CHCS ADM CAPER Data Query Template .txt
Want to edit 'GS CCC CAPER DETAIL' Template? NO// y  (YES)

NAME: GS CCC CAPER DETAIL// 

DESCRIPTION:

  1>Provides ASCII Flat File of 3 E/M & 10 CPT Codes, each with 

  2>2 Modifiers and Units of Service.

  3>CAPER Preview.

EDIT Option: 

READ ACCESS: &SHARKPONDFLYsharkpondflyQq   

WRITE ACCESS: &SHARKPONDFLYsharkpondflyQq   

SETPARAM(PARAM("CNT")+1,"CNT");X

SETPARAM("CLINIC^PT^AIEN^APPT DT^HCP^I1^I2^I3^I4^C1^C1M1^C1M2^C1U^C2^C2M1^C2M2^C2U^C3^C3M1^C3M2^C3U^C4^C4M1^C4M2^C4U^C5^C5M1^C5M2^C5U^C6^C6M1^C6M2^C6U^C7^C7U^C8^C8U^C9^C9U^C10^C10U^E1^EM1^EM2^EU1^E2^EU2^E3^EU3","HEADER1");X

$S(PARAM("CNT")>1:"",1:$C(12,13)_PARAM("HEADER1")_PARAM("HEADER2"));X

KG ADC DATA:

Y

(APPOINTMENT:CLINIC);X

"^"_(APPOINTMENT:NAME);X

"^`"_(APPOINTMENT:NUMBER);X

"^"_RA DATE TIME(APPOINTMENT:APPOINTMENT DATE/TIME);X

"^"_(APPOINTMENT:PROVIDER);X

"^"_1ST(ICD DIAGNOSIS:ICD CODE);X

"^"_2ND(ICD DIAGNOSIS:ICD CODE);X

"^"_3RD(ICD DIAGNOSIS:ICD CODE);X

"^"_4TH(ICD DIAGNOSIS:ICD CODE);X

"^"_1ST(CPT CODE:CPT CODE);X

"^"_1ST(CPT CODE:MOD1);X

"^"_1ST(CPT CODE:MOD2);X

"^"_1ST(CPT CODE:UNITS OF SERVICE);X

"^"_2ND(CPT CODE:CPT CODE);X

"^"_2ND(CPT CODE:MOD1);X

"^"_2ND(CPT CODE:MOD2);X

"^"_2ND(CPT CODE:UNITS OF SERVICE);X

"^"_3RD(CPT CODE:CPT CODE);X

"^"_3RD(CPT CODE:MOD1);X

"^"_3RD(CPT CODE:MOD2);X

"^"_3RD(CPT CODE:UNITS OF SERVICE);X

"^"_4TH(CPT CODE:CPT CODE);X

"^"_4TH(CPT CODE:MOD1);X

"^"_4TH(CPT CODE:MOD2);X

"^"_4TH(CPT CODE:UNITS OF SERVICE);X

"^"_5TH(CPT CODE:CPT CODE);X

"^"_5TH(CPT CODE:MOD1);X

"^"_5TH(CPT CODE:MOD2);X

"^"_5TH(CPT CODE:UNITS OF SERVICE);X

"^"_6TH(CPT CODE:CPT CODE);X

"^"_6TH(CPT CODE:MOD1);X

"^"_6TH(CPT CODE:MOD2);X

"^"_6TH(CPT CODE:UNITS OF SERVICE);X

"^"_7TH(CPT CODE:CPT CODE);X

"^"_7TH(CPT CODE:UNITS OF SERVICE);X

"^"_8TH(CPT CODE:CPT CODE);X

"^"_8TH(CPT CODE:UNITS OF SERVICE);X

"^"_9TH(CPT CODE:CPT CODE);X

"^"_9TH(CPT CODE:UNITS OF SERVICE);X

"^"_10TH(CPT CODE:CPT CODE);X

"^"_10TH(CPT CODE:UNITS OF SERVICE);X

"^"_1ST(EVAL/MGMT CODE:EVAL/MGMT CODE);X

"^"_1ST(EVAL/MGMT CODE:MOD1);X

"^"_1ST(EVAL/MGMT CODE:MOD2);X

"^"_1ST(EVAL/MGMT CODE:UNITS OF SERVICE);X

"^"_2ND(EVAL/MGMT CODE:EVAL/MGMT CODE);X

"^"_2ND(EVAL/MGMT CODE:UNITS OF SERVICE);X

"^"_3RD(EVAL/MGMT CODE:EVAL/MGMT CODE);X

"^"_3RD(EVAL/MGMT CODE:UNITS OF SERVICE);X

  Then Print KG ADC DATA FIELD: 

Then Print FIELD: 

Heading: PATIENT APPOINTMENT LIST  Replace PATIENT APPOINTMENT LIST With @@

Footnote: 

Store Print logic in Template: GS CCC CAPER DETAIL

Are you adding 'GS CCC CAPER DETAIL' as a new PRINT TEMPLATE? Y  (YES)

Do you always want to suppress SubHeaders when printing Template? YES//  (Yes)

DEVICE: 


_1203353163.doc
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SET UP A QUICK LAUNCH TOOLBAR 

Prepared by:


C. C. Colon, Clinical Data Analyst

 (910) 907-9989

Charlene.Colon@na.amedd.army.mil


Purpose


To outline steps to set up a Quick Launch Toolbar to easily access multiple applications or files, such as AHLTA, Message Manager, MS-Word and Excel, to upload/import different file types into CHCS II.   

Summary


The Windows Quick Launch Toolbar is a time-saving feature to easily access different applications on your PC.  There are several excellent features that AHLTA supports, but they require easily switch between MS-Word, Excel, MS Paint and the WAMC CHCS II Image Library available at:  U:\CHCS II.  


Steps to Activate the Quick Launch Toolbar:

1.  Right Mouse Click on an open area of the Taskbar (Next to the Windows Start Button)
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                                Click Here    

2.  Left click on Toolbars then Quick Launch (so it has a checkmark) 
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3.  Click and Drag Desktop Shortcut Icons such as CHCS II and other File or Folder Icons to the Quick Launch.  Make sure the Taskbar is not Locked (Look for the dotted markers). 


4.  Re-order the icons by dragging them into position on the Quick Launch.  


5.  Enlarge the Quick Launch Toolbar by moving your mouse pointer until it changes shape.
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    Drag to the Right


6.  Right Mouse Click on an open area of the Taskbar and Lock the Taskbar.
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